summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2017-08-11 23:12:16 +0200
committerMartchus2017-08-11 23:12:16 +0200
commitec45dfe6685b9c77d07bd9714dae9d5318dd7350 (patch)
tree95cc8ab2cdbc42a2e514331ea0b1e61ab8e4a1cc /PKGBUILD
parent120bb19dffaad5c818595feaf36e1ca3ebe1de82 (diff)
downloadaur-apple-darwin-qt5-declarative.tar.gz
Remove CMake file for QmlDebuggerServiceFactory plugin
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index abd0cdacb9a9..c39c3b8f20d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_qt_module=qtdeclarative
pkgname='apple-darwin-qt5-declarative'
pkgver=5.9.1
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc="Classes for QML and JavaScript languages (apple-darwin)"
depends=('apple-darwin-qt5-base')
@@ -65,6 +65,9 @@ package() {
pushd build-${_arch}-${_config##*=}
make INSTALL_ROOT="$pkgdir" install
+ # QmlDebuggerServiceFactory plugin is not available so remove CMake plugin file for it
+ rm "${pkgdir}/${_osxcrossprefix}/${_arch}/lib/cmake/Qt5Qml/Qt5Qml_QQmlDebuggerServiceFactory.cmake"
+
# Strip the binaries, remove debug libraries
find "${pkgdir}/${_osxcrossprefix}" -name "*.dylib" -a -not -iname '*_debug*' -exec ${_osxcrossprefix}/bin/${_arch}-strip -S -x {} \;
find "${pkgdir}/${_osxcrossprefix}" -name '*.a' -a -not -iname '*_debug.a' -a -not -iname '*DevTools.a' -a -not -iname '*Bootstrap.a' -exec ${_osxcrossprefix}/bin/${_arch}-strip -S -x {} \;