summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2023-06-11 09:50:47 +0200
committerFabioLolix2023-06-11 09:50:47 +0200
commit05644cc4fbe293b7883e142c88bd961365b107c1 (patch)
treedd63aa6d2fb8b9f355c131b0524028d5529bfd53 /PKGBUILD
parent05f976cf58a78dad68dd626c264554fdf7cb90ca (diff)
downloadaur-05644cc4fbe293b7883e142c88bd961365b107c1.tar.gz
v1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7dc9fa16995..84cbadb21e35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Fabien Devaux <fdev31@gmail.com>
pkgname=aqualung
-pkgver=1.1+4+g44a3f40
+pkgver=1.2
pkgrel=1
pkgdesc="High quality music player w/ gapless support"
arch=(i686 x86_64)
url="https://aqualung.jeremyevans.net/"
license=(GPL)
depends=(gtk2 libxml2 alsa-lib sndio jack libpulse liboggz libusb-compat
- libifp ffmpeg4.4 libvorbis libsndfile lua52 wavpack libcdio-paranoia
+ libifp ffmpeg libvorbis libsndfile lua52 wavpack libcdio-paranoia
libmad flac liblrdf libmpcdec libsamplerate)
makedepends=(git ladspa libcddb speex lame libmodplug)
optdepends=('libcddb: CDDB / FreeDB support'
@@ -17,18 +17,11 @@ optdepends=('libcddb: CDDB / FreeDB support'
'lame: MP3 audio support (encode)'
'libmodplug: MOD files support (playback .mod .s3m .xm .it ...)')
_commit=44a3f40d784010a183e1f61cbd02615ff5568358
-source=("git+https://github.com/jeremyevans/aqualung.git#commit=${_commit}"
+source=("git+https://github.com/jeremyevans/aqualung.git#tag=${pkgver}"
aqualung.desktop)
sha256sums=('SKIP'
'4d2aba2924b7c0bacbd377a6975f1cdbf09dc67a5d61c36bf2d52bddbab1b3b9')
-pkgver() {
- cd "${pkgname}"
- git describe --tags | sed 's/^v//;s/-/+/g'
-}
-
-export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
-
prepare() {
cd "${pkgname}"
./autogen.sh