summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsmls2016-02-15 11:04:13 +0100
committersmls2016-02-15 11:13:05 +0100
commit7592d42e6edd2b086f493d991faf896cb27efa90 (patch)
tree105036c6ec8c6ae10bec07092e5b35843fb91aef /PKGBUILD
parent6c60cb5176c18e6eaaa1d25e44b260d3b16da11f (diff)
downloadaur-7592d42e6edd2b086f493d991faf896cb27efa90.tar.gz
add original version number to pkgver
Also, fetch source via a git tag rather than revision, and make the correct version string appear in the main menu in the game.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a7ca8ccf432..44b068f763b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Sam S. <smls75@gmail.com>
pkgname=aquaria-ose
-pkgver=1.002
+_osever=1.002
+pkgver=1.1.3+o$_osever
pkgrel=1
-_gitrev=b86133f
-pkgdesc="A 2D fantasy underwater action-adventure game (Open Source Edition of the engine = official v1.1.3 + many improvements)"
+pkgdesc="A 2D fantasy underwater action-adventure game (Open Source Edition of the engine = original v1.1.3 + many improvements)"
url='http://www.bit-blot.com/forum/index.php?topic=4313.0'
arch=('i686' 'x86_64')
license=('GPL')
@@ -15,15 +15,18 @@ conflicts=('aquaria-hib-git' 'aquaria-hib-hg' 'aquaria' 'aquaria-git' 'aquaria-o
replaces=('aquaria-hib-git' 'aquaria-hib-hg' 'aquaria' 'aquaria-git')
install="$pkgname.install"
-source=("$_gitrev.tar.gz::https://github.com/AquariaOSE/Aquaria/tarball/$_gitrev"
+_repo=Aquaria
+_tag=OSE-v$_osever
+source=("https://github.com/AquariaOSE/$_repo/archive/$_tag.tar.gz"
"aquaria-ose.desktop")
-md5sums=('970fb36585114c9b0ac6d34dfdc3de65'
+md5sums=('edb90261243611a20130b4bd9c2d6a13'
'0d1457aa0fae8ded40c011a7d766e46f')
-_folder=AquariaOSE-Aquaria-$_gitrev
+_folder=$_repo-$_tag
build() {
cd $_folder
cmake -DAQUARIA_DEFAULT_DATA_DIR=/usr/share/aquaria \
+ -DAQUARIA_OVERRIDE_VERSION_STRING="Aquaria OSE $_osever (based on Aquaria v1.1.3)" \
-DAQUARIA_USE_SDL2=1
make
}