summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072020-10-23 15:43:07 +0200
committersL1pKn072020-10-23 15:43:07 +0200
commit3abf6701c19bdffb99ac09859cd16851ed1a8f46 (patch)
treec7baaebf55ad567f1154ce5812daa15016d7740f /PKGBUILD
parente9ec15b047e309fa641508b84020fc4af74921c2 (diff)
downloadaur-3abf6701c19bdffb99ac09859cd16851ed1a8f46.tar.gz
bump patchs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc60eba877e5..d627d08a3447 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,32 @@
pkgname=arc
pkgver=5.21p
-pkgrel=4
+pkgrel=5
pkgdesc="Arc file archiver and compressor. Long since superceeded by zip/unzip but useful if have old .arc files need to unpack."
arch=('x86_64')
url='http://sourceforge.net/projects/arc'
license=('GPL')
source=("http://download.sourceforge.net/arc/arc-${pkgver}.tar.gz"
- 'arc-5.21p-directory-traversel.patch::https://bugs.debian.org/cgi-bin/bugreport.cgi?att=1;bug=774527;filename=arc-5.21p-directory-traversel.patch;msg=10'
- 'arc-5.21p-fix-arcdie.patch::https://bugs.debian.org/cgi-bin/bugreport.cgi?att=2;bug=774527;filename=arc-5.21p-fix-arcdie.patch;msg=10'
- 'arc-5.21p-hdrv1-read-fix.patch::https://bugs.debian.org/cgi-bin/bugreport.cgi?att=3;bug=774527;filename=arc-5.21p-hdrv1-read-fix.patch;msg=10'
+ 'arc-5.21p-directory-traversel.patch::https://salsa.debian.org/debian/arc/-/raw/debian/master/debian/patches/080_arc-5.21p-directory-traversel.patch'
+ 'arc-5.21p-fix-arcdie.patch::https://salsa.debian.org/debian/arc/-/raw/debian/master/debian/patches/070_arc-5.21p-fix-arcdie.patch'
+ 'arc-5.21p-hdrv1-read-fix.patch::https://salsa.debian.org/debian/arc/-/raw/debian/master/debian/patches/060_arc-5.21p-hdrv1-read-fix.patch'
+ 'https://gitweb.gentoo.org/repo/gentoo.git/plain/app-arch/arc/files/arc-5.21p-fno-common.patch'
+ 'fix-gcc-warnings.patch::https://salsa.debian.org/debian/arc/-/raw/debian/master/debian/patches/040_fix-gcc-warnings.patch'
)
sha256sums=('eacf870a245f155a4ba8c6f8e0fbb2e8a267aafa157f56ba7a8cb1d74fd8b5a1'
- 'a2b96695d5714c7c74d47809e01eded3d95c31dc9b435de47cb3c8f4693f0cb4'
- 'bcaa49fae5c139792e8a7117c03c357e0cfc135844f31fcb7c2cbdd8bf407a5e'
- 'b7d4adbb6b32c46929a6f69a53d983449276d0ffcc59d4ce53cde0a1939accd6'
+ '3ec0bf53d40dbe2e05a6dd37ec5ed882aa78cdee36adda6b3829c1534dea9b79'
+ '9af0ba3e6f4ab8a70101aafe412dc8680013ad2d086340d2200611a1442e16b0'
+ '45be47184902c31a0f17268ff4dd2acc83f47fef3567edffcab8b418bd61b121'
+ 'aa80eea84d635a79565870fe076d4487e4b8770d9e065b54428e852a39ef3e40'
+ 'ac902db9fbadda9a917bb06ea4e13f8ef086116e882f5b13d680e4099fa52fca'
)
prepare() {
patch -d "arc-${pkgver}" -p1 -i "${srcdir}/arc-5.21p-hdrv1-read-fix.patch"
patch -d "arc-${pkgver}" -p1 -i "${srcdir}/arc-5.21p-fix-arcdie.patch"
patch -d "arc-${pkgver}" -p1 -i "${srcdir}/arc-5.21p-directory-traversel.patch"
+ patch -d "arc-${pkgver}" -p1 -i "${srcdir}/arc-5.21p-fno-common.patch"
+ patch -d "arc-${pkgver}" -p1 -i "${srcdir}/fix-gcc-warnings.patch"
}
build() {