summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBilal Elmoussaoui2016-06-05 20:53:29 +0200
committerBilal Elmoussaoui2016-06-05 20:53:29 +0200
commit02de60bd9366b676e9d2f675eb77044b5928720b (patch)
tree889db740942015093010009e8f92a039f6505869 /PKGBUILD
downloadaur-02de60bd9366b676e9d2f675eb77044b5928720b.tar.gz
first release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..675a6abfb996
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: ELmoussaoui Bilal <bil.elmoussaoui@gmail.com>
+
+pkgname=arc-icon-theme-git
+_gitname=arc-icon-theme
+pkgver=20160605
+pkgrel=1
+pkgdesc='Arc icon theme'
+arch=(any)
+url=https://github.com/horst3180/arc-icon-theme
+license=('GPL3')
+depends=()
+makedepends=('git' 'gnome-common' 'intltool' 'itstool')
+source=("git://github.com/horst3180/${_gitname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${_gitname}"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ make install
+} \ No newline at end of file