summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorunmellow2024-04-11 01:05:17 -0400
committerunmellow2024-04-11 01:05:17 -0400
commit77c1d1fa335ca9810469c371e3556de64cb033db (patch)
treebe13de4d6cc864aae521adcd676ff681da985feb /PKGBUILD
parent2214fb3269447a5630f387d127a9da0dddb72b98 (diff)
downloadaur-77c1d1fa335ca9810469c371e3556de64cb033db.tar.gz
lietterally stole the suggested changes from @Earnest
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7fcfe81dd777..9df8eb7ddb0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
pkgdesc='Game Engine meets a Display Server meets a Multimedia Framework'
pkgname='arcan-git'
-pkgver=0.5.4.6.r10.gdb2f991e
+pkgver=r4353.ad9686c7
pkgrel=1
license=('GPL2' 'LGPL' 'custom:BSD')
-arch=('x86_64')
+arch=(aarch64 'x86_64')
depends=('freetype2' 'harfbuzz' 'harfbuzz-icu' 'mesa' 'luajit' 'sqlite'
- 'libxkbcommon' 'libvncserver' 'libusb' 'openal' 'ffmpeg' 'apr')
+ 'libxkbcommon' 'libvncserver' 'libusb' 'openal' 'ffmpeg' 'apr' 'wayland-protocols')
makedepends=('cmake' 'ruby' 'git')
provides=('arcan')
conflicts=('arcan')
url='https://arcan-fe.com/'
-source=("${pkgname}::git+https://github.com/letoram/arcan.git")
-sha512sums=('SKIP')
+source=("${pkgname}::git+https://github.com/letoram/arcan.git"
+ "0001-fix-build-werror.patch")
+sha512sums=('SKIP' 'SKIP')
pkgver () {
cd "${pkgname}"
@@ -23,6 +24,11 @@ pkgver () {
)
}
+prepare () {
+ cd "${srcdir}"
+ patch -Np1 -i 0001-fix-build-werror.patch
+}
+
build () {
pushd "${pkgname}/doc" &> /dev/null
ruby docgen.rb mangen
@@ -35,7 +41,7 @@ build () {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DVIDEO_PLATFORM=egl-dri \
- -DSHMIF_TUI_ACCEL=ON \
+ -DHYBRID_SDL=ON \
-DENABLE_LWA=ON \
-DENABLE_LTO=ON \
../src