summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThea Barnes2021-08-16 20:54:27 -0400
committerThea Barnes2021-08-16 20:54:27 -0400
commit3351306ad716db3b067333885631366f2310171c (patch)
tree71d9b2dc8abe1013c8b89b29e1a5bd3e0db5542a /PKGBUILD
downloadaur-3351306ad716db3b067333885631366f2310171c.tar.gz
Initial packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b8947a04554
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Thea Barnes <thea@tsbarnes.com>
+pkgname=arch-yellow-kde-theme-git
+pkgver=r5.9b76e97
+pkgrel=1
+pkgdesc="ArchYellow theme for KDE"
+arch=('any')
+url="https://www.pling.com/p/1575095"
+license=('LGPL3')
+provides=("${pkgname}")
+conflicts=("${pkgname}" "${pkgname}-git")
+options=('!strip')
+source=("ArchYellow::git+https://github.com/tsbarnes/ArchYellow.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/ArchYellow"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+package() {
+ cd "ArchYellow"
+ mkdir -p "$pkgdir/usr/share"
+ cp -drf color-schemes plasma "$pkgdir/usr/share/"
+}