summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAtomicFS2021-11-13 16:50:46 +0100
committerAtomicFS2021-11-13 16:50:46 +0100
commitd2969d823a1d33834b7cf7dca89877b833a3948a (patch)
treede7a2246a3b166bd46f3704539aa81a1c09f3387 /PKGBUILD
downloadaur-d2969d823a1d33834b7cf7dca89877b833a3948a.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b50fc3083d21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dreemurrs Embedded Labs
+pkgname=archarm-mobile-fde-installer-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Script to setup Full-Ddisk-Encryption on Arch Linux ARM for PinePhone and PineTab'
+arch=('any')
+url='https://github.com/dreemurrs-embedded/archarm-mobile-fde-installer'
+license=('custom:none')
+depends=('git' 'openssl')
+optdepends=('gnupg: config import/export support')
+source=("git+https://github.com/dreemurrs-embedded/archarm-mobile-fde-installer.git")
+sha256sums=('SKIP')
+provides=("archarm-mobile-fde-installer=${pkgver}")
+depends=(
+ 'parted'
+ 'cryptsetup'
+ 'sudo'
+ 'wget'
+ 'tar'
+ 'squashfs-tools'
+ 'e2fsprogs'
+ 'f2fs-tools'
+ 'util-linux'
+ 'zstd'
+ 'curl'
+)
+
+package() {
+ cd "archarm-mobile-fde-installer/"
+ install -m 755 -D installer.sh "${pkgdir}/usr/bin/archarm-mobile-fde-installer"
+}