summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTiago Koji Castro Shibata2018-04-06 17:41:22 -0300
committerTiago Koji Castro Shibata2018-04-06 17:41:22 -0300
commit482e5899c9f816f6fed67941f938434d3fc22054 (patch)
treea1c3e5d098ee76cfb7829898dee2280bece33893 /PKGBUILD
parente17a313d8c2b425c6f2f8b410984374af0f6534b (diff)
downloadaur-archc-git.tar.gz
Fix hardcoded paths to prefix and sysconfdir
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6139f5ee7ef0..b84ad0cc8883 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,14 +21,12 @@ pkgver() {
build() {
cd ArchC
./autogen.sh
- ./configure --prefix=$pkgdir/usr
+ ./configure --prefix=/usr --sysconfdir=/etc
make
}
package() {
cd ArchC
- make install
- # Move configuration files to /etc
- mv $pkgdir/{usr/,}etc
+ make prefix=$pkgdir/usr sysconfdir=$pkgdir/etc install
rm $pkgdir/etc/env.sh # Unneeded for a system wide install
}