summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsharcc2021-06-05 15:47:07 -0400
committersharcc2021-06-05 15:47:07 -0400
commit9211efe8f23af83212687d62df8bc5328bbb7faa (patch)
tree95c7807c3d9829223a6440b8a3602ca632d4ccb9 /PKGBUILD
parenta6c1d09dfa6b9d18e78d0e7e89c7a9c0e739e720 (diff)
downloadaur-9211efe8f23af83212687d62df8bc5328bbb7faa.tar.gz
better PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c8dee5d6f04..1a6bcb39aff0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
+# Maintainer: Miten <admin@m1ten.me>
# Maintainer: Anton Hvornum <anton@hvornum.se>
-# Contributor: Giancarlo Razzolini <grazzolini@archlinux.org>
-# Contributor: demostanis worlds <demostanis@protonmail.com>
+_name=archinstall
pkgname=archinstall-git
-pkgver='r2239.a4033a7'
+pkgver='2.3.0.r2239.a4033a7'
pkgrel=1
pkgdesc="Just another guided/automated Arch Linux installer with a twist"
arch=('any')
-url="https://github.com/archlinux/archinstall"
+url="https://github.com/archlinux/$_name"
license=('GPL')
depends=('python')
makedepends=('python-setuptools' 'python-sphinx')
-provides=('python-archinstall')
-conflicts=('python-archinstall')
-source=('git+https://github.com/archlinux/archinstall.git')
-md5sums=('SKIP')
+provides=("python-$_name")
+conflicts=("python-$_name")
+source=("git+https://github.com/archlinux/$_name.git")
+sha256sums=('SKIP')
build() {
- cd "$srcdir/archinstall"
+ cd "$srcdir/$_name"
python setup.py build
make man -C docs
}
package() {
- cd "$srcdir/archinstall"
+ cd "$srcdir/$_name"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -vDm 644 docs/_build/man/archinstall.1 -t "${pkgdir}/usr/share/man/man1/"
+ install -vDm 644 docs/_build/man/$_name.1 -t "${pkgdir}/usr/share/man/man1/"
}