summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsharcc2021-06-05 12:51:02 -0400
committersharcc2021-06-05 12:51:02 -0400
commita6c1d09dfa6b9d18e78d0e7e89c7a9c0e739e720 (patch)
tree3b1e871055f145ec9e19c6a8bffc8d126e7cfb1d /PKGBUILD
downloadaur-a6c1d09dfa6b9d18e78d0e7e89c7a9c0e739e720.tar.gz
archinstall-git on aur
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c8dee5d6f04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Anton Hvornum <anton@hvornum.se>
+# Contributor: Giancarlo Razzolini <grazzolini@archlinux.org>
+# Contributor: demostanis worlds <demostanis@protonmail.com>
+
+pkgname=archinstall-git
+pkgver='r2239.a4033a7'
+pkgrel=1
+pkgdesc="Just another guided/automated Arch Linux installer with a twist"
+arch=('any')
+url="https://github.com/archlinux/archinstall"
+license=('GPL')
+depends=('python')
+makedepends=('python-setuptools' 'python-sphinx')
+provides=('python-archinstall')
+conflicts=('python-archinstall')
+source=('git+https://github.com/archlinux/archinstall.git')
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/archinstall"
+ python setup.py build
+ make man -C docs
+}
+
+package() {
+ cd "$srcdir/archinstall"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -vDm 644 docs/_build/man/archinstall.1 -t "${pkgdir}/usr/share/man/man1/"
+}