summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlessio2023-07-26 18:07:37 +0200
committerAlessio2023-07-26 18:07:37 +0200
commit216c41f9d8fa210f6776cade56694a01a6eb02e7 (patch)
treefb168e46b78e7c61fca68a89e19ecc53d6511f7e /PKGBUILD
parentf17d1ec7055d1bf09ff9b5b4486ddd91f38764d2 (diff)
downloadaur-archivebox-git.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c60c6e2be7b3..31456c01a448 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Hauke Rehfeld <aur.archlinux.org@haukerehfeld.de>
+# Mantainer: Alessio <alessio@linux.com>
+# Contributor: Hauke Rehfeld <aur.archlinux.org@haukerehfeld.de>
pkgname=archivebox-git
-pkgver=r969.737c5c3
-pkgrel=7
-pkgdesc="Create a local, static, browsable HTML clone of websites (it saves HTML, JS, media files, PDFs, images and more)."
+pkgver=0.5.4.r749.40ddd33
+pkgrel=1
+pkgdesc="Create a local, staticm browsable archive of websites."
arch=('x86_64' 'i686')
url="https://github.com/pirate/ArchiveBox/"
depends=('python' 'git' 'wget' 'curl' 'youtube-dl' 'chromium')
@@ -12,21 +13,19 @@ conflicts=("${pkgname%-git}")
replaces=()
backup=()
options=()
-source=("archivebox::git+${url}")
+source=("archivebox::git+${url}#branch=dev")
noextract=()
-md5sums=('SKIP')
+sha256sums=('SKIP')
license=('MIT')
pkgver() {
cd "$srcdir/${pkgname%-git}"
+ git describe --long | sed 's/^v//;s/-rc./rc/;s/\([^-]*-\)g/r\1/;s/-/./g'
- # Git, no tags available
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd "$srcdir/${pkgname%-git}"
- git checkout master
}
package() {