summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Lass2019-03-23 14:09:20 +0100
committerMichael Lass2019-03-23 14:09:28 +0100
commit5e5fe07d9a30454773edeb67c5619eae9d0e608b (patch)
tree7bd7c56c425073a1d3610dbf09fdbeba6dbb6edc /PKGBUILD
parent9506b5ccbb40fb9077e12a2d3281f7603296c9dd (diff)
downloadaur-5e5fe07d9a30454773edeb67c5619eae9d0e608b.tar.gz
Update to v5
* use tar file instead of git checkout * utilize new build system
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 92700e45eacc..b4484938f57c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,17 @@
# https://github.com/michaellass/AUR
pkgname=archlinux-java-run
-pkgver=4
+pkgver=5
pkgrel=1
pkgdesc="Java Application Launcher for Arch Linux"
arch=(any)
url="https://github.com/michaellass/archlinux-java-run"
license=('MIT')
depends=(bash java-runtime-common)
-makedepends=(git)
-source=("archlinux-java-run::git+https://github.com/michaellass/archlinux-java-run.git#tag=v${pkgver}")
-sha256sums=('SKIP')
+source=(https://github.com/michaellass/${pkgname}/archive/v${pkgver}.tar.gz)
+sha256sums=('eae4381967bfabbff4705e8b7e42627d9d2e3f667d20af09c9938bf92d9db5c2')
package() {
- cd "${srcdir}/${pkgname}"
- install -Dm755 archlinux-java-run.sh "${pkgdir}"/usr/bin/archlinux-java-run
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
- install -Dm644 README.md "${pkgdir}"/usr/share/doc/${pkgname}/README.md
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
}