summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302015-06-17 15:21:50 +0200
committerM0Rf302015-06-17 15:21:50 +0200
commit1c8dcdedfca6a26de49b2dda5896369f485414cc (patch)
tree07fe92ad1dcdc6367df050cd74216096b57ca615 /PKGBUILD
downloadaur-1c8dcdedfca6a26de49b2dda5896369f485414cc.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cef4f1fb3653
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: M0Rf30
+
+pkgname=archweb-git
+pkgver=1911.ffaa2cf
+pkgrel=1
+pkgdesc="Arch website code"
+arch=('i686' 'x86_64')
+url="http://projects.archlinux.org/archweb.git/"
+license=('GPL')
+depends=('python2-django' 'python2-south' 'python2-bencode' 'python2-memcached' 'python2-pyinotify' 'python2-psycopg2' 'python2-markdown' 'python2-pytz' 'pgpdump-git')
+makedepends=('git')
+install=$pkgname.install
+source=('archweb::git://projects.archlinux.org/archweb.git')
+
+package() {
+ mkdir -p $pkgdir/srv/http
+ cp -r archweb $pkgdir/srv/http/
+ rm -r $pkgdir/srv/http/archweb/.git*
+}
+
+pkgver() {
+ cd archweb
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+md5sums=('SKIP')