summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantinos2017-06-17 19:27:54 +0300
committerKonstantinos2017-06-17 19:27:54 +0300
commitd783781341a48a10a3432de603a223d2b9a9a72a (patch)
treed0885500c3e76ab9f406064ec1f68b1a9dbe4a81 /PKGBUILD
downloadaur-arcueid-git.tar.gz
useful commit message
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0443c2cc775b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Konstantinos Foutzopoulos <mail@konfou.xyz>
+
+_pkgname=arcueid
+pkgname=${_pkgname}-git
+pkgver=0.1.2.r413.gb71408e4
+pkgrel=1
+pkgdesc="A C interpreter for Paul Graham's Arc dialect of Lisp. (GIT version)"
+arch=('x86_64' 'i686')
+url="https://arcueid-arc.org"
+license=('GPL3')
+depends=('gmp')
+makedepends=('git')
+optdepends=('readline')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+https://github.com/dido/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --long | sed -e 's/v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd ${_pkgname}
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${_pkgname}
+ install -D -m644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: