summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGimmeapill2016-10-26 00:00:04 +0200
committerGimmeapill2016-10-26 00:00:04 +0200
commit1f16aed16437cf75f68e9b42dd90cb7bd5d1435e (patch)
treef42dfa69fa15b01bad117a530dfd53dff1d651a2 /PKGBUILD
parent6a7b2e3774bd856a1be78dc20e13c572ec41cd5f (diff)
downloadaur-1f16aed16437cf75f68e9b42dd90cb7bd5d1435e.tar.gz
updated dependencies and build flags for Ardour 5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a4f3d7feb19..30e25ae7bfe6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Boohbah <boohbah at gmail.com>
+# Maintainer: Gimmeapill <gimmeapill at gmail dot com>
+# Contributor: Boohbah <boohbah at gmail.com>
# Contributor: SpepS <dreamspepser at yahoo.it>
# Contributor: Bernardo Barros <bernardobarros at gmail.com>
# Contributor: Uli Armbruster <uli_armbruster at web.de>
@@ -6,21 +7,21 @@
_pkgname=ardour
pkgname="${_pkgname}-git"
-pkgver=4.2.r16.g041b31d
+pkgver=5.4.r227.g24846f4
pkgrel=1
pkgdesc="A multichannel hard disk recorder and digital audio workstation"
arch=('i686' 'x86_64')
url="http://ardour.org/"
license=('GPL')
depends=('aubio' 'cwiid' 'gtkmm' 'liblo' 'liblrdf' 'libltc' 'lilv' 'suil'
- 'rubberband' 'taglib')
-makedepends=('git' 'python2' 'boost' 'cppunit' 'doxygen' 'graphviz')
+ 'rubberband' 'taglib' 'fluidsynth' 'libarchive' 'hidapi')
+makedepends=('git' 'python2' 'boost' 'cppunit' 'doxygen' 'graphviz' 'itstool')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("${_pkgname}::git://github.com/Ardour/ardour.git"
'ardour.desktop')
md5sums=('SKIP'
- '151094720b3cdcce2d66b30915dea536')
+ 'd4e6590ea931cbb539a159d3565802a2')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -42,8 +43,9 @@ build() {
--lxvst \
--optimize \
--with-backends=jack,alsa,dummy \
- --use-external-libs \
- --cxx11
+ --cxx11 \
+ --no-phone-home
+# --use-external-libs
python2 waf build $MAKEFLAGS
}
@@ -53,7 +55,7 @@ package() {
python2 waf --destdir="${pkgdir}" install
- # Install freedesktop.org compatibile applictaion starter desktop file
+ # Install freedesktop.org compatible application starter desktop file
install -Dm644 "${srcdir}/ardour.desktop" \
"${pkgdir}/usr/share/applications/ardour.desktop"
}