summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGimmeapill2016-11-04 21:05:34 +0100
committerGimmeapill2016-11-04 21:05:34 +0100
commit559f1ee34e7c7a8eea68090885493afe2dd25d6f (patch)
tree04399391fbadca06dfa5a602c7f0764ede15c72c /PKGBUILD
parentf31ed11f51c42e6a728cd2337e03b2d21a403937 (diff)
downloadaur-559f1ee34e7c7a8eea68090885493afe2dd25d6f.tar.gz
still messing around with deps. currently using the same build flags as the official 5.x package in testing
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c12c140f07d9..a73b1ef88267 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname=ardour
pkgname="${_pkgname}-git"
-pkgver=5.4.r229.g8d70b76
+pkgver=5.4.r257.g1457050
pkgrel=1
pkgdesc="A multichannel hard disk recorder and digital audio workstation"
arch=('i686' 'x86_64')
@@ -32,14 +32,14 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- python2 waf configure \
- --prefix=/usr \
- --configdir=/etc \
- --docs \
- --freedesktop \
- --with-backends=jack,alsa,dummy \
- --cxx11
-# --qm-dsp-include=${srcdir}/ardour/libs/qm-dsp/base/Pitch.h
+ python2 waf configure --prefix=/usr \
+ --configdir=/etc \
+ --with-backends="jack,alsa,dummy " \
+ --libjack=weak \
+ --optimize \
+ --docs \
+ --cxx11 \
+ --no-phone-home
python2 waf build $MAKEFLAGS
}