summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2019-09-27 12:35:58 +0100
committerGrey Christoforo2019-09-27 12:35:58 +0100
commit59c1a5f66ae29a644cf9061ea33b1dcd74f09a67 (patch)
tree45723647f7c9287c1fc8da529f6c0cc41630f9ca /PKGBUILD
parent790e7761f4dd8fce5b179751b3ef4f09b80fdd98 (diff)
downloadaur-59c1a5f66ae29a644cf9061ea33b1dcd74f09a67.tar.gz
fix ctags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 013ece551c22..5e2a2b4c55a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url="https://github.com/arduino/ArduinoCore-samd"
license=('GPL')
provides=('arduino-samd-core')
conflicts=('arduino-samd-core')
-depends=('avrdude' 'avr-gcc' 'avr-libc') ## this needs to be fixed to include arm compiler
+depends=('arduino-ctags') ## this needs to be fixed to include the analogs to: avrdude, avr-gcc and avr-libc
options=(!strip !emptydirs)
source=("https://github.com/arduino/ArduinoCore-samd/archive/${pkgver}.tar.gz"
"platform.patch")
@@ -21,11 +21,13 @@ prepare()
mv "ArduinoCore-samd-${pkgver}" ${pkgname//-rc}-${pkgver}
cd "${srcdir}/${pkgname//-rc}-${pkgver}"
-
# Update version in patchfile, then apply it
sed -i "s/^version=.*/ version=${pkgver}/" "${srcdir}/platform.patch"
patch -Np1 -i "${srcdir}/platform.patch"
+ echo "tools.ctags.path=/usr/bin" >> platform.txt
+ echo "tools.ctags.cmd.path={path}/arduino-ctags" >> platform.txt
+
# Remove elf files
find . -name "*.elf" -type f -exec rm -f {} \;
find . -name "*.a" -type f -exec rm -f {} \;