summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2020-03-23 02:00:15 -0400
committeracxz2020-03-23 02:00:15 -0400
commit8f4095b2cb0c83819da4784336ae67fa328dbde7 (patch)
tree3c47c5bfaefe01d180b3795f786ad2097d31f9df /PKGBUILD
downloadaur-8f4095b2cb0c83819da4784336ae67fa328dbde7.tar.gz
create ardupilot-gazebo-sitl-git package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..110a6b1aacd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+pkgname=ardupilot-gazebo-sitl-git
+pkgver=r31.9bae0ea
+pkgrel=1
+pkgdesc="Gazebo plugin for Ardupilot's SITL."
+arch=('x86_64')
+url='https://ardupilot.org/dev/docs/using-gazebo-simulator-with-sitl.html'
+license=('GPLv3')
+depends=('gazebo')
+optdepends=('ardupilot-sitl')
+makedepends=('cmake')
+provides=('ardupilot-gazebo-sitl')
+_pkgname=ardupilot-gazebo-stil
+source=("${_pkgname}::git+https://github.com/khancyr/ardupilot_gazebo.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ mkdir -p ${srcdir}/${_pkgname}/build
+ cd ${srcdir}/${_pkgname}/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_PREFIX="/usr"
+
+ make
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}/build
+ make DESTDIR="$pkgdir/" install
+}