summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Stelle2017-09-14 12:00:22 -0600
committerGeorge Stelle2017-09-14 12:00:22 -0600
commit3e098ab549a6a78863420a2970c5993dbcb4a1ae (patch)
tree45e0f70248f8df57245df9ced2a82d4ba5e0b073 /PKGBUILD
downloadaur-3e098ab549a6a78863420a2970c5993dbcb4a1ae.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cd60f15faf3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: George Stelle <stelleg@gmail.com>
+pkgname=argobots-git
+pkgver=v1.0a1.r46.g8394f8a
+pkgrel=1
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+pkgdesc="Lightweight, low-level threading and tasking framework"
+arch=('x86_64')
+url=""
+license=('GPL')
+source=("$pkgname"::"git+https://github.com/pmodels/argobots.git")
+noextract=()
+md5sums=('SKIP')
+makedepends=('git automake autoconf gcc libtool')
+
+build() {
+ cd "$pkgname"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}