summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée2016-06-24 14:52:34 +0200
committerMattias Andrée2016-06-24 14:52:34 +0200
commit3ba2a16b0cb382a888e90350f0faaff49b3470fa (patch)
tree950862b8f2aed77ea64094dfe5bed8478dbe026a /PKGBUILD
downloadaur-argparser-python.tar.gz
Initial import, version 5.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11967d273f27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=argparser-python
+pkgver=5.1
+pkgrel=1
+pkgdesc="Command line argument parser library, like getopt, except better. Python version."
+arch=('any')
+url="https://github.com/maandree/argparser"
+license=('AGPL3')
+makedepends=('coreutils' 'sed')
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('10cbff3d7c17d5c8e99dab20e5b425e1da7625dd4090d6c904c944b8bb64195f')
+
+
+build() {
+ cd "${srcdir}/argparser-${pkgver}"
+ make DESTDIR="$pkgdir" PKGNAME="$pkgname" PY3VERSION="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1,2)" \
+ python
+}
+
+package() {
+ cd "${srcdir}/argparser-${pkgver}"
+ make DESTDIR="$pkgdir" PKGNAME="$pkgname" PY3VERSION="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1,2)" \
+ install-python install-license
+}
+