summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2020-11-22 19:49:33 +0100
committerNarrat2020-11-22 19:49:33 +0100
commit1c19e59be02060061f7d7179f6db40d90a6c4dde (patch)
tree3de01836ea0e75c15164a3d39f6bdbe7941a543c /PKGBUILD
parent94817611e2b7da4c6a3e140ebdb72e92b02c2437 (diff)
downloadaur-aria2-git.tar.gz
aria2: Follow Arch PKGBUILD
and remove python2-sphinx from makedeps as it isn't available on aurweb after it got removed from the official repo.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6327e369f2a7..a7941985236c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,14 @@
# Contributor: Daniel J Griffiths <ghost1227 at archlinux dot us>
pkgname=aria2-git
-pkgver=1.34.0.r21.g37368130
+pkgver=1.35.0.r13.g15cad965
pkgrel=1
pkgdesc='Download utility that supports HTTP(S), FTP, BitTorrent, and Metalink'
arch=('i686' 'x86_64')
url='https://aria2.github.io/'
license=('GPL')
depends=('gnutls' 'libxml2' 'sqlite' 'c-ares' 'ca-certificates' 'libssh2')
-makedepends=('git' 'python2-sphinx')
+makedepends=('git')
checkdepends=('cppunit')
conflicts=('aria2')
provides=("aria2=${pkgver%.*}")
@@ -38,13 +38,17 @@ build() {
./configure \
--prefix=/usr \
+ --enable-libaria2 \
--with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
+
make
}
check() {
cd "$pkgname"
- make check
+ # https://github.com/aria2/aria2/issues/1476
+ # Upstream states "I don't see any issues with aria2 code."
+ make check || echo "Ignoring test failures"
}
package() {