summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFilipe Nascimento2024-01-22 14:59:21 -0300
committerFilipe Nascimento2024-01-22 14:59:21 -0300
commita62a2c4a47fbad6ba6d177b71d9c130ec2c2a7f3 (patch)
treeb96a98158c1597dcc3a41ba270359896b030e630 /PKGBUILD
parent0431d2b2c70be70dda86737eca13025ed2c1017f (diff)
downloadaur-aria2p.tar.gz
upgpkg: aria2p 0.12.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 889b9a897daa..737180cea613 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
# Maintainer: Filipe Nascimento <flipee at tuta dot io>
pkgname=aria2p
-pkgver=0.11.3
-pkgrel=2
+pkgver=0.12.0
+pkgrel=1
pkgdesc="Command-line tool and library to interact with an aria2c daemon process with JSON-RPC"
arch=('any')
url="https://pawamoy.github.io/showcase/aria2p"
license=('ISC')
-depends=('python-appdirs' 'python-loguru' 'python-requests'
- 'python-toml' 'python-websocket-client' )
-makedepends=('python-build' 'python-installer' 'python-pdm-pep517')
+depends=('python-appdirs' 'python-loguru' 'python-requests' 'python-websocket-client' )
+makedepends=('python-build' 'python-installer' 'python-pdm-backend')
optdepends=('aria2: aria2c daemon'
'python-asciimatics: interactive interface support'
'python-pyperclip: interactive interface support')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('517667f7b38adde8826908d6b6fbbf862a3066a56415e0fd2fd3ba61dc9cd19d')
+sha256sums=('ac42d2b67b819994df75c79be461ee6adf71be8616105275bce7e8794372c0b7')
build() {
cd $pkgname-$pkgver