summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDictator Mei2018-12-01 19:53:08 +0900
committerDictator Mei2018-12-01 19:53:08 +0900
commitf847c6cd4775cd88494d8a22e9e9e246dcda2a13 (patch)
tree13e96b5ee9425783f42e1a9c8e43fa2be4b0792d /PKGBUILD
downloadaur-f847c6cd4775cd88494d8a22e9e9e246dcda2a13.tar.gz
Site updated: 2018-12-01 19:53:08
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1808ecc95c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Dct Mei <dctxmei@gmail.com>
+pkgname=ariang-allinone
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="AriaNg, a modern web frontend making aria2 easier to use. (all-in-one version)"
+arch=('any')
+url="https://github.com/mayswind/AriaNg"
+license=('MIT')
+depends=("xdg-utils")
+source=("https://github.com/mayswind/AriaNg/releases/download/1.0.0/AriaNg-1.0.0-AllInOne.zip"
+ "$pkgname")
+sha512sums=("f4e6eeb894a6a3aa35da4589460823565b53f286a139bd20c7e9371b9da1c36d579848205a00787a9d708f231d8bce346fdd8afbb7c26c387c0e5ef3c01b3721"
+ "17aed8ae60919025b45741f21ac9485546199003e9fa9c1414fbf2934cbffe090678e3bb2b3f22b2b7d112ac68123a483a0a1f41f9f6781dc98a55442db62af9")
+
+package() {
+ install -Dm644 index.html "$pkgdir/usr/share/$pkgname/index.html"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+}