summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMuflone2017-01-22 14:30:22 +0100
committerMuflone2017-01-22 14:30:22 +0100
commiteabef4d6d102c5bc1cfc59efc01e8f1e23aa31a5 (patch)
tree4fd0ba95a0b02dcf845435c382d73b85b036df51 /PKGBUILD
downloadaur-arista.tar.gz
Moving from community
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 00000000000..8c6df5d5eb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 174186 2016-05-07 16:10:24Z muflone $
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: SergHeart
+
+pkgname=arista
+pkgver=0.9.7
+pkgrel=12
+pkgdesc="Easy to use multimedia transcoder for the GNOME Desktop"
+arch=('any')
+url="http://transcoder.org/"
+license=('LGPL2.1')
+depends=('pygtk' 'python2-gconf' 'python2-dbus' 'librsvg' 'python2-gudev' 'gstreamer0.10-python' 'desktop-file-utils')
+optdepends=('pywebkitgtk: show in-app codecs help'
+ 'python2-notify: show notifications in your desktop environment'
+ 'gstreamer0.10-ffmpeg: enable FFMpeg based audio/video plugins'
+ 'gstreamer0.10-base-plugins: enable basic set of well-supported audio/video plugins'
+ 'gstreamer0.10-good-plugins: enable a set of well-supported free audio/video plugins'
+ 'gstreamer0.10-bad-plugins: enable a set of less supported audio/video plugins'
+ 'gstreamer0.10-ugly-plugins: enable a set of well-supported non-free audio/video plugins')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/danielgtaylor/${pkgname}/archive/${pkgver}.tar.gz"
+ "fix-for-python2.patch"
+ "gst-webkit-imports.patch"
+ "remove-arista-nautilus_py.patch")
+sha256sums=('87d5530d9c7bf2b8ca60f0d356b1a7e431e1798f72db8c5f14f1eba6cecd1cca'
+ '7f783c54122eb4b47b121a3a47ee69d552cb6f1b5a78ed6836b48f12d2b1883d'
+ '625c2767a36e591b38ef31e28dddb8e45218b632ce2a150f12ed2eed34746406'
+ '704fd490fb48e334abc84274e6e9012bd514afd4cf33313dd34fc96eacf83c7b')
+conflicts=('arista-transcoder')
+replaces=('arista-transcoder')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -p1 -i "../fix-for-python2.patch"
+ patch -p1 -i "../gst-webkit-imports.patch"
+ # The script arista-nautilus.py doesn't work with Nautilus 3.x
+ patch -p1 -i "../remove-arista-nautilus_py.patch"
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}"
+}