summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTyler Veness2017-07-14 16:10:05 -0400
committerTyler Veness2017-08-17 22:19:25 -0700
commit7c838686e331528ef82a9a5b2210d023d3c13e86 (patch)
tree7a96dea5965d9c0c25f400f2c8bc42f2c1d7592f /PKGBUILD
parent8b1f0cd4486640ec28820ec1c08e3bb6daf39df6 (diff)
downloadaur-7c838686e331528ef82a9a5b2210d023d3c13e86.tar.gz
Updated to NI 2017 feed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a68160a1a145..8fc74925d480 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,10 @@
_target="arm-frc-linux-gnueabi"
pkgname=${_target}-eglibc
-pkgver=2.21
-_basever=2.21-r0.83
-pkgrel=2
+pkgver=2.23
+_basever=2.23-r0.47
+_year=2017
+pkgrel=1
pkgdesc="Embedded GNU C Library (${_target})"
arch=(any)
url="http://www.eglibc.org"
@@ -13,16 +14,16 @@ license=('GPL')
groups=('frc-toolchain')
depends=("${_target}-linux-api-headers")
options=('!strip' 'staticlibs' '!emptydirs')
-source=("http://download.ni.com/ni-linux-rt/feeds/2016/arm/ipk/cortexa9-vfpv3/libc6_${_basever}_cortexa9-vfpv3.ipk"
- "http://download.ni.com/ni-linux-rt/feeds/2016/arm/ipk/cortexa9-vfpv3/libc6-dev_${_basever}_cortexa9-vfpv3.ipk"
- "http://download.ni.com/ni-linux-rt/feeds/2016/arm/ipk/cortexa9-vfpv3/libcidn1_${_basever}_cortexa9-vfpv3.ipk"
- "http://download.ni.com/ni-linux-rt/feeds/2016/arm/ipk/cortexa9-vfpv3/libc6-thread-db_${_basever}_cortexa9-vfpv3.ipk"
- "http://download.ni.com/ni-linux-rt/feeds/2016/arm/ipk/cortexa9-vfpv3/libc6-extra-nss_${_basever}_cortexa9-vfpv3.ipk")
-md5sums=('b0ebbf81bf8967e3c4cb4015e377c96c'
- '1f69e9ef7f61edad53bf325e2a83f6b2'
- '9e1a5b62312d0dba50a07b79c237e4ac'
- '49e2138e2d36ba014a891a5a41d628b9'
- '2fea5da4b5dbfc52dfc387d64935b9e1')
+source=("http://download.ni.com/ni-linux-rt/feeds/${_year}/arm/ipk/cortexa9-vfpv3/libc6_${_basever}_cortexa9-vfpv3.ipk"
+ "http://download.ni.com/ni-linux-rt/feeds/${_year}/arm/ipk/cortexa9-vfpv3/libc6-dev_${_basever}_cortexa9-vfpv3.ipk"
+ "http://download.ni.com/ni-linux-rt/feeds/${_year}/arm/ipk/cortexa9-vfpv3/libcidn1_${_basever}_cortexa9-vfpv3.ipk"
+ "http://download.ni.com/ni-linux-rt/feeds/${_year}/arm/ipk/cortexa9-vfpv3/libc6-thread-db_${_basever}_cortexa9-vfpv3.ipk"
+ "http://download.ni.com/ni-linux-rt/feeds/${_year}/arm/ipk/cortexa9-vfpv3/libc6-extra-nss_${_basever}_cortexa9-vfpv3.ipk")
+md5sums=('3b99022865f148ed4a846ee0d7693160'
+ 'ba4d47fc0090395805f79e7e2d79b769'
+ '7886688bd23948702c0956216228d51c'
+ '9461c536f1eb2cc3ea3f47fdacc8c0cc'
+ '806ccabe20694def89af3e44fdf6fd03')
package() {
cd "${srcdir}"