summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Anderson2018-01-23 15:56:00 +0000
committerAndrew Anderson2018-01-23 15:56:00 +0000
commit32d1fb28f56b892e17d283dc7dc324cab101b80e (patch)
tree03d82c278d1d0f88291e988afc70251ed83ac34e /PKGBUILD
downloadaur-32d1fb28f56b892e17d283dc7dc324cab101b80e.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdb958eb70b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Andrew Anderson <aanderso@tcd.ie>
+
+pkgname=arm-linux-gnueabihf-armcl-opencl+neon
+pkgver=17.12
+pkgrel=0
+
+epoch=
+pkgdesc="ARM Computer Vision and Machine Learning Library (armv7a OpenCL + NEON Backends)"
+arch=( 'x86_64' )
+url="https://github.com/ARM-software/ComputeLibrary"
+license=('MIT')
+groups=()
+depends=()
+makedepends=( 'scons>=2.3' 'git' 'doxygen>=1.8.5' 'arm-linux-gnueabihf-gcc' )
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=( 'arm-linux-gnueabihf-armcl-neon' )
+replaces=()
+backup=()
+options=( !strip )
+install=
+changelog=
+source=("git+https://github.com/ARM-software/ComputeLibrary.git")
+sha1sums=('SKIP')
+
+build() {
+ cd "${srcdir}/ComputeLibrary"
+ git checkout "v$pkgver"
+ scons -j2 \
+ os=linux arch=armv7a build=cross_compile \
+ Werror=0 debug=0 asserts=0 \
+ neon=1 \
+ opencl=1 gles_compute=0 embed_kernels=1 \
+ examples=0 \
+ set_soname=0 \
+ openmp=0 cppthreads=1 \
+ pmu=0 \
+ mali=0 \
+ validation_tests=0 \
+ benchmark_tests=0
+}
+
+#check() {}
+
+package() {
+ cd "${srcdir}/ComputeLibrary"
+ mkdir -p ${pkgdir}/usr/arm-linux-gnueabihf/lib/
+ cp -r build/*.a ${pkgdir}/usr/arm-linux-gnueabihf/lib/
+ cp -r build/*.so ${pkgdir}/usr/arm-linux-gnueabihf/lib/
+
+ mkdir -p ${pkgdir}/usr/arm-linux-gnueabihf/include/arm_compute/
+ cp -r arm_compute/* ${pkgdir}/usr/arm-linux-gnueabihf/include/arm_compute/
+}