summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTavian Barnes2019-07-04 14:49:16 -0400
committerTavian Barnes2019-07-04 16:39:23 -0400
commit307ce42251b293cfb66012af19ebce79cb566a26 (patch)
tree17e9590ddf0648c6fdb336b71bf6f19afb103070 /PKGBUILD
parent99cef4ba620f3a10cdfbd36920cf49ab5dc832ae (diff)
downloadaur-307ce42251b293cfb66012af19ebce79cb566a26.tar.gz
Bump to 2.32-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 7 insertions, 40 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5e4e6696e57..00318a07658f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,36 +7,19 @@
_target="arm-linux-gnueabihf"
pkgname=${_target}-binutils
-pkgver=2.31.1
-pkgrel=4
+pkgver=2.32
+pkgrel=2
pkgdesc="A set of programs to assemble and manipulate binary and object files (${_target})"
arch=(i686 x86_64)
-url='http://www.gnu.org/software/binutils/'
+url='https://www.gnu.org/software/binutils/'
license=(GPL)
depends=(glibc zlib)
checkdepends=(dejagnu bc)
options=(staticlibs !distcc !ccache)
-source=(http://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig}
- 0001-PR23428-x86-Add-a-GNU_PROPERTY_X86_ISA_1_USED-note-if-needed.patch
- 0002-PR23460-Close-resource-leaks-in-the-BFD-library-s-plugin-han.patch
- 0003-PR23460-Add-a-testcase-for-PR-binutils-23460.patch
- 0004-PR23486-Properly-merge-GNU_PROPERTY_X86_ISA_1_USED-x86_64.patch
- 0005-PR23486-x86-Properly-merge-GNU_PROPERTY_X86_ISA_1_USED.patch
- 0006-PR23428-x86-Properly-add-X86_ISA_1_NEEDED-property.patch
- 0007-PR23919-Handle-ELF-compressed-header-alignment.patch
- 0008-PR23919-gold-Get-alignment-of-uncompressed-section.patch
-)
+source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig})
validpgpkeys=(3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F)
-md5sums=('5b7c9d4ce96f507d95c1b9a255e52418'
- 'SKIP'
- 'f2d4f2aee9ec2e25210eb132acdcf1d9'
- '496e7e2d71fe558b3b85cdc27fb4638e'
- 'dd2284134542efe8e38137f5c829a371'
- '5e4aecddbea729fd045d001e8e8db14e'
- '02247a5f1c06f8a9ade689b7e68629ce'
- '2764b8760bdc8d5c20698202d22b7fcf'
- '5db54b24fb9de56d66111f63aea3b809'
- '201036d5806b7b037eb53bf796219525')
+md5sums=('0d174cdaf85721c5723bf52355be41e6'
+ 'SKIP')
prepare() {
mkdir -p binutils-build
@@ -44,22 +27,6 @@ prepare() {
#cd binutils-gdb
cd binutils-$pkgver
- # https://sourceware.org/bugzilla/show_bug.cgi?id=23428
- # https://sourceware.org/bugzilla/show_bug.cgi?id=23486
- patch -Np1 -i ../0001-PR23428-x86-Add-a-GNU_PROPERTY_X86_ISA_1_USED-note-if-needed.patch
- patch -Np1 -i ../0004-PR23486-Properly-merge-GNU_PROPERTY_X86_ISA_1_USED-x86_64.patch
- patch -Np1 -i ../0005-PR23486-x86-Properly-merge-GNU_PROPERTY_X86_ISA_1_USED.patch
- patch -Np1 -i ../0006-PR23428-x86-Properly-add-X86_ISA_1_NEEDED-property.patch
-
- # https://sourceware.org/bugzilla/show_bug.cgi?id=23460
- patch -Np1 -i ../0002-PR23460-Close-resource-leaks-in-the-BFD-library-s-plugin-han.patch
- patch -Np1 -i ../0003-PR23460-Add-a-testcase-for-PR-binutils-23460.patch
-
- # FS#61151
- # https://sourceware.org/bugzilla/show_bug.cgi?id=23919
- patch -Np1 -i ../0007-PR23919-Handle-ELF-compressed-header-alignment.patch
- patch -Np1 -i ../0008-PR23919-gold-Get-alignment-of-uncompressed-section.patch
-
# hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
}
@@ -104,7 +71,7 @@ check() {
package() {
cd binutils-build
- make prefix="$pkgdir/usr" tooldir="$pkgdir/usr" install
+ make DESTDIR="$pkgdir" install
# Remove unwanted files
rm -rf "$pkgdir/usr/share"