summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTavian Barnes2018-05-11 10:46:16 -0400
committerTavian Barnes2018-05-11 10:46:16 -0400
commitefc11959bc88c912a65d75b95adb566247e303ea (patch)
tree583ea2139a8c01e53f09ccad20b076028d855536 /PKGBUILD
parent657430ed348162cbbc79057c42de709a26a66d91 (diff)
downloadaur-efc11959bc88c912a65d75b95adb566247e303ea.tar.gz
Bump to 2.30-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 35 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 454eb8e772cd..02400c08e5a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,71 @@
# Contributor: Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
# Contributor: toha257 <toha257@gmail.com>
# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Kevin Mihelich <kevin@archlinuxarm.org>
# Maintainer: Tavian Barnes <tavianator@tavianator.com>
_target="arm-linux-gnueabihf"
pkgname=${_target}-binutils
-pkgver=2.29.0
-_basever=2.29
-pkgrel=1
-_commit=dd9a28c0966d13924fbd1096a724ae334954d830
+pkgver=2.30
+pkgrel=4
pkgdesc="A set of programs to assemble and manipulate binary and object files (${_target})"
arch=(i686 x86_64)
url='http://www.gnu.org/software/binutils/'
license=(GPL)
-depends=('glibc>=2.26' zlib)
+depends=(glibc zlib)
+checkdepends=(dejagnu bc)
options=(staticlibs !distcc !ccache)
-source=(#git://sourceware.org/git/binutils-gdb.git#commit=${_commit}
- http://ftp.gnu.org/gnu/binutils/binutils-${_basever}.tar.bz2)
-md5sums=('23733a26c8276edbb1168c9bee60e40e')
+source=(http://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig}
+ 0001-PR22741-objcopy-segfault-on-fuzzed-COFF-object.patch
+ 0002-PR22829-objcopy-strip-removes-PT_GNU_RELRO-from-lld-.patch
+ 0003-PR22836-r-s-doesnt-work-with-g3-using-GCC-7.patch)
+validpgpkeys=(3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F)
+md5sums=('ffc476dd46c96f932875d1b2e27e929f'
+ 'SKIP'
+ '469164f3c93a0e92a697537b60c9806c'
+ '0c679b37e90fb23de60a4d28329b956a'
+ '53b5682e09c0a27e9994c3efdfe01d29')
prepare() {
mkdir -p binutils-build
- cd "binutils-$_basever"
+ #cd binutils-gdb
+ cd binutils-$pkgver
# hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+
+ # https://sourceware.org/bugzilla/show_bug.cgi?id=22741
+ patch -p1 -i "$srcdir/0001-PR22741-objcopy-segfault-on-fuzzed-COFF-object.patch"
+
+ # https://sourceware.org/bugzilla/show_bug.cgi?id=22829
+ patch -p1 -i "$srcdir/0002-PR22829-objcopy-strip-removes-PT_GNU_RELRO-from-lld-.patch"
+
+ # https://sourceware.org/bugzilla/show_bug.cgi?id=22836
+ patch -p1 -i "$srcdir/0003-PR22836-r-s-doesnt-work-with-g3-using-GCC-7.patch"
}
build() {
cd binutils-build
- "$srcdir/binutils-${_basever}/configure" \
+ "$srcdir/binutils-$pkgver/configure" \
--prefix=/usr \
--program-prefix=${_target}- \
--with-lib-path=/usr/lib/binutils/${_target} \
--with-local-prefix=/usr/lib/${_target} \
--with-sysroot=/usr/${_target} \
- --enable-threads \
- --enable-shared \
- --enable-ld=default \
+ --enable-deterministic-archives \
--enable-gold \
+ --enable-ld=default \
+ --enable-lto \
--enable-plugins \
--enable-relro \
- --enable-deterministic-archives \
- --with-pic \
- --disable-werror \
+ --enable-shared \
+ --enable-threads \
--disable-gdb \
+ --disable-werror \
+ --with-pic \
--with-system-zlib \
--disable-sim \
--target=${_target} \
@@ -60,7 +78,7 @@ build() {
check() {
cd binutils-build
-
+
# unset LDFLAGS as testsuite makes assumptions about which ones are active
# ignore failures in gold testsuite...
make -k LDFLAGS="" check || true