summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVyacheslav Razykov2021-04-09 00:17:36 +0300
committerVyacheslav Razykov2021-04-09 00:19:30 +0300
commitcc3abd87c4aea44526fd427b4fb8d0557978d1f1 (patch)
tree94431dd4059606cc443244056ca43f671147242a /PKGBUILD
parent39fc86e3e849e91ed071e6ed05b13fac8a498b73 (diff)
downloadaur-cc3abd87c4aea44526fd427b4fb8d0557978d1f1.tar.gz
Update to 10.3.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 7 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5546ab83e181..28bc62a7b975 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,34 +7,30 @@
_target="arm-linux-gnueabihf"
pkgname=${_target}-gcc-stage2
-pkgver=10.2.0
+pkgver=10.3.0
_majorver=${pkgver%%.*}
_islver=0.21
-pkgrel=2
+pkgrel=1
pkgdesc="The GNU Compiler Collection. Stage 2 for toolchain building (${_target})"
arch=(i686 x86_64)
license=(GPL LGPL FDL custom)
url='https://gcc.gnu.org'
-depends=("${_target}-binutils>=2.36.1-1" "${_target}-glibc-headers>=2.33-1" libmpc zlib)
+depends=("${_target}-binutils>=2.36.1-1" "${_target}-glibc-headers>=2.33-2" libmpc zlib)
options=(!emptydirs !distcc !strip)
conflicts=("${_target}-gcc-stage1")
replaces=("${_target}-gcc-stage1")
provides=("${_target}-gcc-stage1=${pkgver}")
source=(https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz{,.sig}
http://isl.gforge.inria.fr/isl-${_islver}.tar.xz
- fs64270.patch
- ipa-fix-bit-CPP-when-combined-with-IPA-bit-CP.patch
- ipa-fix-ICE-in-get_default_value.patch)
+ all_default-ssp-fix.patch)
validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org
86CFFCA918CF3AF47147588051E8B148A9999C34 # evangelos@foutrelis.com
13975A70E63C361C73AE69EF6EEB81F8981C74C7 # richard.guenther@gmail.com
33C235A34C46AA3FFB293709A328C3A2C3C45C06) # Jakub Jelinek <jakub@redhat.com>
-sha256sums=('b8dd4368bb9c7f0b98188317ee0254dd8cc99d1e3a18d0ff146c855fe16c1d8c'
+sha256sums=('64f404c1a650f27fc33da242e1f2df54952e3963a49e06e73f6940f3223ac344'
'SKIP'
'777058852a3db9500954361e294881214f6ecd4b594c00da5eee974cd6a54960'
- '1ef190ed4562c4db8c1196952616cd201cfdd788b65f302ac2cc4dabb4d72cee'
- 'fcb11c9bcea320afd202b031b48f8750aeaedaa4b0c5dddcd2c0a16381e927e4'
- '42865f2af3f48140580c4ae70b6ea03b5bdca0f29654773ef0d42ce00d60ea16')
+ '5481035e3a714c6ad7bbf06b342c8b278a474b131d88e3cdc00a6221fe4d12ac')
prepare() {
[[ ! -d gcc ]] && ln -s gcc-${pkgver/+/-} gcc
@@ -51,13 +47,7 @@ prepare() {
# Turn off SSP for nostdlib|nodefaultlibs|ffreestanding
# https://bugs.archlinux.org/task/64270
- patch -p1 -i "$srcdir/fs64270.patch"
-
- # Fix a crash in mpv when mesa 20.2 is compiled with LTO
- # https://gitlab.freedesktop.org/mesa/mesa/-/issues/3239
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=96482
- patch -Np1 -i ../ipa-fix-bit-CPP-when-combined-with-IPA-bit-CP.patch
- patch -Np1 -i ../ipa-fix-ICE-in-get_default_value.patch
+ patch -p1 -i "$srcdir/all_default-ssp-fix.patch"
mkdir -p "$srcdir/gcc-build"
}