summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTavian Barnes2016-05-16 18:27:18 -0400
committerTavian Barnes2016-05-16 18:35:05 -0400
commit8c0eb6b1aedf0f7216cb46f0e8c232ab0c97aaac (patch)
tree10745473e9f95f5a10be038ea281835063b861f9 /PKGBUILD
parentdf7acce01c6558ad9b70dbababb695d069790805 (diff)
downloadaur-8c0eb6b1aedf0f7216cb46f0e8c232ab0c97aaac.tar.gz
Bump to 2.23-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e78f43ca471f..71cd2fd536f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,24 +7,31 @@
_target="arm-linux-gnueabihf"
pkgname=${_target}-glibc
pkgver=2.23
-pkgrel=1
+pkgrel=4
+_commit=a37d61a6
pkgdesc="GNU C Library (${_target})"
arch=('any')
url="http://www.gnu.org/software/libc/"
license=('GPL' 'LGPL')
-depends=("${_target}-linux-api-headers>=4.4.1")
-makedepends=("${_target}-gcc-stage2>=5.3.0" 'gperf')
+depends=("${_target}-linux-api-headers>=4.5.2")
+makedepends=("${_target}-gcc-stage2>=6.1.1" 'gperf')
provides=("${_target}-glibc-headers=${pkgver}" "${_target}-eglibc")
conflicts=("${_target}-glibc-headers" "${_target}-eglibc")
replaces=("${_target}-glibc-headers")
options=('!buildflags' '!strip' 'staticlibs')
-source=(http://ftp.gnu.org/gnu/libc/glibc-${pkgver}.tar.xz{,.sig})
+source=(http://ftp.gnu.org/gnu/libc/glibc-${pkgver}.tar.xz{,.sig}
+ glibc-${_commit}.patch.xz)
md5sums=('456995968f3acadbed39f5eba31678df'
- 'SKIP')
+ 'SKIP'
+ 'bd20955ffd9d0b4ee246e7cca20430bc')
validpgpkeys=('F37CDAB708E65EA183FD1AF625EF0A436C2A4AFF') # Carlos O'Donell
prepare() {
- mkdir glibc-build
+ cd glibc-${pkgver}
+
+ patch -p1 -i ${srcdir}/glibc-${_commit}.patch
+
+ mkdir ${srcdir}/glibc-build
}
build() {