summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPellegrino Prevete2022-12-26 14:32:55 +0000
committerPellegrino Prevete2022-12-26 14:32:55 +0000
commitab328b193fff841ff5fe9edd8ef09f3e11f77d5a (patch)
tree2efcb8d78d4cbc0bd906f51ca2d7da06ec374788 /PKGBUILD
parent2165a01ef2805ce1008b986f26df46be299983c3 (diff)
downloadaur-ab328b193fff841ff5fe9edd8ef09f3e11f77d5a.tar.gz
update isl
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1270bbb4c80..ac214f938db8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,31 @@
-# Maintainer: Georgios Kourachanis < geo dot kourachanis at gmail dot com >
+# Maintainer: Pellegrino Prevete < pellegrinoprevete at gmail dot com >
+# Contributor: Georgios Kourachanis < geo dot kourachanis at gmail dot com >
# Contributor: Anatol Pomozov < anatol dot pomozov at gmail dot com > (arm-none-eabi-gcc)
# Contributor: Martin Schmölzer < mschmoelzer at gmail dot com > (arm-none-eabi-gcc)
-_target=arm-none-eabi
-pkgname=$_target-gcc55
+_target="arm-none-eabi"
+_pkgbase="gcc"
+pkgname="${_target}-${_pkgbase}55"
pkgver=5.5.0
-_islver=0.18
+_islver=0.24
pkgrel=1
# _snapshot=7-20170907
pkgdesc='The GNU Compiler Collection - cross compiler for ARM EABI (bare-metal) target'
arch=(i686 x86_64)
-url='http://gcc.gnu.org/'
+_domain="${_pkgbase}.gnu.org"
+url="http://${_domain}"
+_ftp_url="ftp://${_domain}/pub/${_pkgbase}"
license=(GPL LGPL FDL)
-depends=($_target-binutils zlib libmpc)
-makedepends=(gmp mpfr $_target-newlib)
-provides=('arm-none-eabi-gcc')
-conflicts=('arm-none-eabi-gcc')
-optdepends=('arm-none-eabi-newlib: Standard C library optimized for embedded systems')
+depends=("${_target}-binutils" "zlib" "libmpc")
+makedepends=("gmp" "mpfr" "${_target}-newlib")
+provides=("${_target}-gcc")
+conflicts=("${_target}-gcc")
+optdepends=("${_target}-newlib: Standard C library optimized for embedded systems")
options=(!emptydirs !strip)
-source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.xz
- #ftp://gcc.gnu.org/pub/gcc/snapshots/$_snapshot/gcc-$_snapshot.tar.xz
- http://isl.gforge.inria.fr/isl-$_islver.tar.bz2
- enable-with-multilib-list-for-arm.patch)
+source=("ftp://${_pkgbase_url}/releases/${_pkgbase}-${pkgver}/${_pkgbase}-${pkgver}.tar.xz"
+ # "ftp://${_pkgbase_url}/snapshots/${_snapshot}/${_pkgbase}-${_snapshot}.tar.xz"
+ "https://${_pkgbase_url}/infrastructure/isl-${_islver}.tar.bz2"
+ "enable-with-multilib-list-for-arm.patch")
sha512sums=('670ff52c2ae12c7852c12987e91798c5aa8bd6daf21f0d6e0cd57a4aa59cc4f06a837fe76426eaa1424cfddca937bed377680700eadc04d76b9180d462364fa1'
'85d0b40f4dbf14cb99d17aa07048cdcab2dc3eb527d2fbb1e84c41b2de5f351025370e57448b63b2b8a8cf8a0843a089c3263f9baee1542d5c2e1cb37ed39d94'
'4831a862a0ee50918297f35da48919f326ad9e8b3a2a97d4b130e08c0e781a0e6c44e918d2618ba73be2ce0f8d0365b063ed5650a4bd8a5e26ee37a78647b2d2')