summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKoffeinFlummi2016-05-09 17:12:36 +0200
committerKoffeinFlummi2016-05-09 17:12:36 +0200
commiteb00bfdc9b10565053b3706b6f8617a274d3e70a (patch)
tree5046467e85e96b96e2c2235019ba96f54dae0164 /PKGBUILD
parentb5fcb52bb57abbe8b77635512f7bd1086bb15424 (diff)
downloadaur-eb00bfdc9b10565053b3706b6f8617a274d3e70a.tar.gz
Add pkgver function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d814aa6c334..9261a2f9c2cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname="armake"
pkgname="${_pkgname}-git"
-pkgver=0.2.1
+pkgver=0.2.1.r0.g11b6889
pkgrel=1
pkgdesc="An open-source implementation of the Arma modding tools."
arch=('i686' 'x86_64')
@@ -13,6 +13,11 @@ optdepends=()
source=("git+https://github.com/KoffeinFlummi/armake.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | tail -c +2 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd "${srcdir}/${_pkgname}"
make