summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuint Guvernator2015-11-30 00:33:32 +0100
committerQuint Guvernator2015-11-30 00:33:32 +0100
commitdb706300b2f731102bfb145dffebd4db138928a0 (patch)
treefc8b4ebfa5f41f5f0a39a01b307795ac2bd4e11a /PKGBUILD
downloadaur-db706300b2f731102bfb145dffebd4db138928a0.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4508160cc83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Quint Guvernator <quint@guvernator.net>
+pkgname=arms-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=1.0.0.r0.78fba94
+pkgrel=1
+pkgdesc="ARMS: The Arch Regular Maintenance Script"
+arch=('any')
+url="https://github.com/qguv/arms"
+license=('GPL')
+depends=('sudo')
+makedepends=('git')
+optdepends=('reflector: to automatically update the mirrorlist'
+ 'lostfiles: to locate files not managed by pacman (AUR)')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('arms::git+https://github.com/qguv/arms')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/v//')"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -D arms "$pkgdir/usr/bin/arms"
+}