summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrea Gómez2021-03-27 01:53:14 -0500
committerAndrea Gómez2021-03-27 01:53:14 -0500
commit2d5aa00096d61b173ffcbd92c03f5b2522fd9866 (patch)
treed017f92399617d0e0d47f1630a7462db00a6e31f /PKGBUILD
parent4b2154681f8cb3f18e0b3be89bef2b63ccb08e4e (diff)
downloadaur-2d5aa00096d61b173ffcbd92c03f5b2522fd9866.tar.gz
Update arpfox to latest version
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD46
1 files changed, 29 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44e0306a6023..9dab3c8b45af 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,45 @@
-# Maintainer: Andrea 'alephZer0' Gómez <crypto.andrea at protonmail dot ch>
-# GitHub: -> https://github.com/da-edra
+# Maintainer: Andrea Denisse Gómez-Martínez <aur at denisse dot dev>
pkgname=arpfox
-pkgver=0.9.9
+pkgdesc='An arpspoof alternative (written in Go) that injects spoofed ARP packets into a LAN.'
+arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url='https://github.com/malfunkt/arpfox'
+_branch='master'
+pkgver=1.0.0
pkgrel=1
-pkgdesc="An arpspoof alternative written in Go that injects specially crafted
-ARP packets into a LAN."
-arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
-url="https://github.com/malfunkt/arpfox"
license=('MIT')
-depends=('libpcap')
-makedepends=('go-pie')
-provides=("arpfox")
-conflicts=("arpfox")
+makedepends=(go)
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('50f151a0b8bcd309e77e7d9f83b1badaf14ba085f8fc85d5e23c0d1923c2550e')
+sha256sums=('f2b24dc840381264ea6f010cc5f0949089611083d9310a91ffda2a770a074ec4')
+sha512sums=('150ea193235c555a528de2bfe5a0f6e06fd91a46cc979004f103acc1f8175381633c4817a1bf0d37cd142d72d20f610b55ef94ebabf41fbd27152bdc430219c0')
+provides=($pkgname)
+conflicts=($pkgname)
prepare() {
- export GO111MODULE=on
+ cd "${pkgname}-${pkgver}"
+ mkdir build
+ go mod tidy
}
build() {
cd "${pkgname}-${pkgver}"
- go build
+
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ go build -o build/ .
}
-package() {
+check() {
cd "${pkgname}-${pkgver}"
+ go test ./...
+}
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dsm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}