summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrea Denisse2019-09-21 00:08:11 -0500
committerAndrea Denisse2019-09-21 00:10:52 -0500
commitb3027a767ca0ab20ac743c68000a7509d658a939 (patch)
treeee18db98223bc5b8d5261fb188e2adc41029cb39 /PKGBUILD
downloadaur-b3027a767ca0ab20ac743c68000a7509d658a939.tar.gz
Upload arpfox to the AUR
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..2dc675521161
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Andrea 'alephZer0' Gómez <crypto.andrea at protonmail dot ch> -> https://github.com/da-edra
+
+pkgname=arpfox
+pkgver=0.9.9
+pkgrel=1
+pkgdesc="An arpspoof alternative written in Go that injects specially crafted ARP packets into a LAN."
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/malfunkt/arpfox"
+license=('MIT')
+depends=('libpcap')
+makedepends=('go')
+provides=("arpfox")
+conflicts=("arpfox")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/malfunkt/arpfox/archive/v${pkgver}.tar.gz")
+sha256sums=('50f151a0b8bcd309e77e7d9f83b1badaf14ba085f8fc85d5e23c0d1923c2550e')
+
+build() {
+ go get github.com/malfunkt/arpfox
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make VERSION=$pkgver DESTDIR="$pkgdir" PREFIX=/usr install
+}