summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorclintval2017-11-01 14:37:48 -0700
committerclintval2017-11-01 14:37:48 -0700
commit8ed09fc067f7237d7d1d6709ffa4fda37b14f888 (patch)
tree86d70ef148d0da402f2905e98395436ecf71aa56 /PKGBUILD
downloadaur-8ed09fc067f7237d7d1d6709ffa4fda37b14f888.tar.gz
First commit with PKGBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77b7489644b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='artemis'
+pkgver='16.0.0'
+pkgrel=1
+pkgdesc='Artemis is a free genome viewer and annotation tool that allows visualization of sequence features and the results of analyses within the context of the sequence, and its six-frame translation.'
+arch=('i686' 'x86_64')
+url=http://www.sanger.ac.uk/resources/software/"${artemis}"
+license=('GPL2')
+depends=('java-runtime>=1.6')
+provides=('artemis')
+conflicts=('artemis')
+source=(ftp://ftp.sanger.ac.uk/pub/resources/software/"${pkgname}"/"${pkgname}".tar.gz)
+md5sums=('bf6d9d9df113b8676857e3eb3dedd990')
+
+package() {
+ cd "${srcdir}"/"${pkgname}"
+
+ mkdir -p "${pkgdir}"/usr/bin
+ mkdir -p "${pkgdir}"/opt/"${pkgname}"/
+
+ cp -a * "${pkgdir}"/opt/"${pkgname}"/
+
+ scripts=('act' 'art' 'dnaplotter')
+
+ for script in "${scripts[@]}"
+ do
+ ln -s "${pkgdir}"/opt/artemis/"${script}" "${pkgdir}"/usr/bin/"${script}"
+ done
+
+ install -Dm644 README "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}