summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDeckweiss2023-02-25 14:26:17 +0100
committerDeckweiss2023-02-25 14:26:17 +0100
commitca0398a8350f3dfc270ff4923f6cfe48e99dd682 (patch)
treeb2b30b0a673e1a5902940b0e80848c70f06d3617 /PKGBUILD
downloadaur-ca0398a8350f3dfc270ff4923f6cfe48e99dd682.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15765e937481
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Deckweiss <Deckweiss75@gmail.com>
+
+_name="arttime"
+pkgname="${_name}-git"
+pkgver=1.0.453
+pkgrel=1
+pkgdesc="Arttime brings curated text-art to otherwise artless terminal emulators of starving developers and other users who can use terminal."
+arch=('any')
+url="https://github.com/poetaman/${_name}"
+license=('GPLv3')
+depends=(
+ 'zsh'
+)
+makedepends=(
+ 'zsh'
+)
+conflicts=(${_name})
+provides=(${_name})
+source=("git+https://github.com/poetaman/$_name.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ printf "1.0.%s" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ cd "$_name"
+ ./install.sh --prefix "$pkgdir/usr/local/" --zcompdir "$pkgdir/usr/share/zsh/site-functions"
+}