summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsmls2016-05-21 21:01:01 +0200
committersmls2016-05-21 21:01:01 +0200
commit338ab5471931d9a7083f9ca03551cf29b47f0e46 (patch)
tree4c0ed18e08779dd7643d52e992105d722878ba14 /PKGBUILD
parent89c36777ff4b361c64aa322bae55fb7d8ba1fa5f (diff)
downloadaur-338ab5471931d9a7083f9ca03551cf29b47f0e46.tar.gz
Use pre-build icons from separate git repo
Arx Libertatis switched to generating its icons at build-time using Inkscape. To avoid having Inkscape as a build dependency, a separate ArxLibertatisData repo has been provided with the pre-build icons. The Gentoo package is already using it: https://github.com/arx/ArxGentoo/commit/9b93bbf
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f63ff717c3bd..a419e8680162 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=arxlibertatis-git
_installname=arx
-pkgver=1.1.2+r5464.gc87968a
+pkgver=1.1.2+r6979.g96cd0b6
pkgrel=1
pkgdesc='Cross-platform port of Arx Fatalis, a first-person fantasy RPG (executables only; latest git revision)'
url='http://arx-libertatis.org/'
@@ -19,17 +19,19 @@ optdepends=('arxfatalis-data-gog: game data from GOG.com installer'
makedepends=('git' 'cmake' 'boost')
provides=('arx')
replaces=('arx-git')
-conflicts=('arx arx-git arxlibertatis')
+conflicts=('arx' 'arx-git' 'arxlibertatis')
install=arx.install
_gitname=ArxLibertatis
-source=(git+https://github.com/arx/ArxLibertatis.git)
-md5sums=('SKIP')
+_data_gitname=ArxLibertatisData
+source=("git+https://github.com/arx/$_gitname.git"
+ "git+https://github.com/arx/$_data_gitname.git")
+md5sums=('SKIP' 'SKIP')
pkgver() {
cd $_gitname
_version=$(git describe --tags $(git rev-list --tags --max-count=1))
- _commits=$(git log 1.1.2..master --pretty=oneline | wc -l)
+ _commits=$(git log $_version..master --pretty=oneline | wc -l)
_rev=$(git log -1 --format="%h")
echo "$_version+r$_commits.g$_rev"
}
@@ -37,7 +39,8 @@ pkgver() {
build() {
cd $_gitname
- cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake . -DDATA_FILES=../$_data_gitname \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_INSTALL_LIBEXECDIR=lib/$_installname \
-DINSTALL_DATADIR=share/$_installname \
@@ -51,7 +54,7 @@ build() {
#
# CMAKE_BUILD_TYPE=Release
# can be changed to CMAKE_BUILD_TYPE=Debug to get a debug build,
- # which will run signifincantly slower but enables more runtime
+ # which will run significantly slower but enables more runtime
# checks and generates better crash reports.
make