summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212022-07-10 15:53:56 +0200
committera8212022-07-10 15:53:56 +0200
commit52595e0d0c7e0fc9a80e3b9f8195a31df677b16a (patch)
tree0422470349aed7f87165e11567cdef988a180a31 /PKGBUILD
parent42b08cee7abc2215f0067f411511f77040344fe8 (diff)
downloadaur-asciinema-git.tar.gz
Takeover and update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91e400df4217..9293e33ed2ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,34 @@
-# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Maintainer: a821
+# Contributor: Frederic Bezies <fredbezies at gmail dot com>
# Contributor: sudokode <sudokode@gmail.com>
# Contributor: Marcin Kulik <m@kulik.com>
-name=asciinema
pkgname=asciinema-git
-pkgver=2.0.0.r67.g350d5e9
+pkgver=2.2.0.r18.g5a38576
pkgrel=1
-pkgdesc="Record and share your terminal sessions, the right way"
+pkgdesc="Record and share your terminal sessions"
arch=('any')
-url="https://github.com/asciinema/$name"
-license=('MIT')
-makedepends=('git' 'python')
-conflicts=("$name")
-source=("$pkgname::git+https://github.com/asciinema/${name}.git")
+url="https://github.com/asciinema/asciinema"
+license=('GPL3')
+depends=('python')
+makedepends=('git' 'python-setuptools' 'python-wheel' 'python-build' 'python-installer')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+source=("$pkgname::git+${url}.git")
sha256sums=('SKIP')
pkgver() {
cd $pkgname
- git describe --long | sed 's/^v//; s/\([^-]*-g\)/r\1/; s/-/./g'
+ git describe --long --tags | sed -e 's/^v//;s/-/.r/;s/-/./g'
}
+build() {
+ cd $pkgname
+ python -m build --wheel --no-isolation
+}
package() {
cd $pkgname
-
- python setup.py install --root="$pkgdir/" install
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim:set ts=2 sw=2 et: