summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorImperatorStorm2022-03-11 15:24:20 -0800
committerImperatorStorm2022-03-11 15:30:08 -0800
commit2123a4ee687ed827d5aba6b8363053e2fb1e6d31 (patch)
tree3fbb0257e72c9c7e7b8e92f5310cd9fad13fe089 /PKGBUILD
parent7f62495148c8b3118078b4c4197aae26878e238b (diff)
downloadaur-2123a4ee687ed827d5aba6b8363053e2fb1e6d31.tar.gz
Further improvements to Aseprite PKGBUILD.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53a8a466cd9f..ab17bd27970b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,7 +48,8 @@ source=("https://github.com/aseprite/aseprite/releases/download/v$pkgver/Aseprit
shared-libwebp.patch
shared-skia-deps.patch
optional-pixman.patch)
-noextract=("${source[0]##*/}") # Don't extract Aseprite sources at the root
+noextract=("Aseprite-v$pkgver-Source.zip"
+ "skia-$_skiaver.tar.gz") # Don't extract Aseprite or skia sources at the root
sha256sums=('c3a86005f59483fcfcedae89bf82dfc6f82bba8d5244835ca4c005beab31435b'
'aa999a6d457f657e0a895340870aa84256ef9b7b65d1c4f107b51461119495ff'
'8b14e36939e930de581e95abf0591645aa0fcfd47161cf88b062917dbaaef7f9'
@@ -64,7 +65,7 @@ prepare() {
bsdtar -xf "${noextract[0]}" -C aseprite
# Extract Skia's sources
mkdir -p skia
- bsdtar -xf skia-$_skiaver.tar.gz -C skia
+ bsdtar xf skia-$_skiaver.tar.gz --strip-components=1 -C skia
# Fix up Aseprite's desktop integration
env -C aseprite patch -tp1 <desktop.patch
# Allow using more shared libs