diff options
author | Gilrain | 2023-02-16 11:07:21 +0100 |
---|---|---|
committer | Gilrain | 2023-02-16 11:07:21 +0100 |
commit | a227d55e7da50beabc8f22824e180a5b2acf9008 (patch) | |
tree | d051074089018eb2305d11d03065f804109aaf0d /PKGBUILD | |
parent | 234a3ac70965a89489ada22135b31b2ab7174689 (diff) | |
download | aur-a227d55e7da50beabc8f22824e180a5b2acf9008.tar.gz |
explicit building instructions (replace cc.sh script)
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 13 |
1 files changed, 8 insertions, 5 deletions
@@ -14,6 +14,7 @@ arch=('x86_64' 'armv7h' 'aarch64') url="https://github.com/JustArchiNET/ArchiSteamFarm" license=('Apache') makedepends=('git' 'dotnet-sdk>=7.0' 'aspnet-runtime>=7.0') +dotnet_framework='net7.0' changelog=changelog install=install source=("asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=${pkgver}" @@ -35,11 +36,13 @@ prepare() { build() { cd asf export DOTNET_CLI_TELEMETRY_OPTOUT=1 - ./cc.sh --no-pull --no-asf-ui - - export DOTNET_FLAGS="-c Release -f net7.0 -p:ContinuousIntegrationBuild=true -p:UseAppHost=false --nologo" - export PUBLISH_FLAGS="-r "$(uname -s)"-"$(uname -m)" --no-self-contained" - #dotnet publish "ArchiSteamFarm.OfficialPlugins.ItemsMatcher" -o "out/result/plugins/ArchiSteamFarm.OfficialPlugins.ItemsMatcher" $DOTNET_FLAGS $PUBLISH_FLAGS + [[ "$CARCH" == "x86_64" ]] && architecture="x64" + [[ "$CARCH" == "armv7h" ]] && architecture="arm" + [[ "$CARCH" == "aarch64" ]] && architecture="arm64" + export DOTNET_FLAGS="--configuration Release --framework "${dotnet_framework}" -p:UseAppHost=false --nologo" + export PUBLISH_FLAGS="--runtime linux-"${architecture}" --no-self-contained" + dotnet publish "ArchiSteamFarm" -o "out/result" $DOTNET_FLAGS $PUBLISH_FLAGS + dotnet publish "ArchiSteamFarm.OfficialPlugins.ItemsMatcher" -o "out/result/plugins/ArchiSteamFarm.OfficialPlugins.ItemsMatcher" $DOTNET_FLAGS $PUBLISH_FLAGS dotnet publish "ArchiSteamFarm.OfficialPlugins.SteamTokenDumper" -o "out/result/plugins/ArchiSteamFarm.OfficialPlugins.SteamTokenDumper" $DOTNET_FLAGS $PUBLISH_FLAGS dotnet publish "ArchiSteamFarm.OfficialPlugins.MobileAuthenticator" -o "out/result/plugins/ArchiSteamFarm.OfficialPlugins.MobileAuthenticator" $DOTNET_FLAGS $PUBLISH_FLAGS dotnet publish "ArchiSteamFarm.CustomPlugins.PeriodicGC" -o "out/result/plugins/ArchiSteamFarm.CustomPlugins.PeriodicGC" $DOTNET_FLAGS $PUBLISH_FLAGS |