summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOliver Breitwieser2021-08-03 13:53:18 +0200
committerOliver Breitwieser2021-08-03 13:53:18 +0200
commitffa3a45abcf9ee756255dd7fb21fa34841c2d0da (patch)
tree4f56a69a658af03fe9b181909076af66209ee535 /PKGBUILD
parent8239926a4c67df413bb215ddde42da27c35883c7 (diff)
downloadaur-ffa3a45abcf9ee756255dd7fb21fa34841c2d0da.tar.gz
Add missing manpages for commands
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42cdc8f495af..4ccb7cd8d3d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=asfa
pkgver=0.9.0
-pkgrel=1
+pkgrel=2
pkgdesc='share files by upload via ssh and generation of a non-guessable link'
arch=('x86_64')
url="https://github.com/obreitwi/asfa"
@@ -20,7 +20,9 @@ build() {
_folder_man=target/release/man
mkdir -p ${_folder_man}/man1
help2man "${_path_bin}" > ${_folder_man}/man1/${pkgname}.1
- for cmd in clean list push verify; do
+ # Find all named commands (except for aliases that need to be added afterwards)
+ (find "src/cmd" -not -name "mod.rs" -type f -exec basename '{}' '.rs' \; ; echo "mv")\
+ | while read -r cmd; do
help2man "'$_path_bin' $cmd" > ${_folder_man}/man1/${pkgname}-${cmd}.1
done
}