summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRokyErickson2018-12-01 19:33:00 +0000
committerRokyErickson2018-12-01 19:33:00 +0000
commitd10c6355e2fa7a637156e76d5fb7695a485e58a6 (patch)
tree783c44ec84b5c7e8227243f57b27eedb9ef5752c /PKGBUILD
downloadaur-d10c6355e2fa7a637156e76d5fb7695a485e58a6.tar.gz
inital non-functioning commit of Aspera
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48e0bdc77448
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: 13floorelevators <the13thfloorelevators@protonmail.com> <BURST-737A-XKSG-M424-67UVT>
+
+pkgname=aspera-git
+_realname=Aspera
+pkgver=v1.0
+pkgrel=1
+pkgdesc="My fork of PoCC's BURST aspera"
+arch=('x86_64')
+url="https://github.com/RokyErickson/Aspera"
+license=('GPL3')
+makedepends=(go dep git go)
+source=("git"+"https://github.com/RokyErickson/Aspera.git")
+sha256sums=('SKIP')
+pkgver() {
+ cd "${srcdir}"
+ git describe --always --long --tags | sed
+'s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+_importpath="github.com/RokyErickson/${_realname}"
+
+prepare() {
+ export GOPATH="${srcdir}/_go"
+ mkdir -p $(dirname "$GOPATH/src/${_importpath}/")
+ ln -sf "${srcdir}/${_realname}" "$GOPATH/src/${_importpath}"
+ cd "$GOPATH/src/${_importpath}"
+ dep ensure -v
+}
+
+check() {
+ export GOPATH="${srcdir}/_go"
+ cd "$GOPATH/src/${_importpath}"
+ # see https://github.com/snail007/goproxy/issues/156
+ #go test $(go list ./...)
+}
+
+build() {
+ export GOPATH="${srcdir}/_go"
+ cd "$GOPATH/src/${_importpath}"
+ go build
+}
+
+package() {
+ export GOPATH="$srcdir/_go"
+ cd "$GOPATH/src/${_importpath}"
+ install -dm755 "$pkgdir/usr/bin"
+ install -m755 "${_realname}" "$pkgdir/usr/bin/${_realname}"
+}
+
+