summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikhail Velichko2022-12-22 19:27:05 +0300
committerMikhail Velichko2022-12-22 19:27:05 +0300
commitb291b7cf11f1315cbc7c4032d67c9f2282a35e1d (patch)
treec91e25b74af0abc209391d5e7cacfa4c19b71546 /PKGBUILD
downloadaur-ast-firmware.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6479671aa690
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Mikhail Velichko <efklid@gmail.com>
+
+
+pkgname=ast-firmware
+pkgver=501
+pkgrel=1
+pkgdesc="Aspeed VGA module from the IPMI"
+url="https://www.supermicro.com/support/faqs/faq.cfm?faq=26876"
+license=('custom')
+arch=('any')
+source=("ast_dp501_fw.tar.gz::https://github.com/Labaman/ast-firmware/raw/main/ast_dp501_fw.tar.gz")
+sha256sums=('58c24d2d5f5fb2b8eb000aef83b510c0ec95c87cdcd769620e489c589d7ae60a')
+
+build() {
+ bsdtar xvf "ast_dp501_fw.tar.gz"
+ chmod 644 "${srcdir}/ast_dp501_fw.bin"
+}
+
+package() {
+ install -Dm644 ${srcdir}/ast_dp501_fw.bin ${pkgdir}/usr/lib/firmware/ast_dp501_fw.bin
+}