summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2023-04-02 12:36:11 -0300
committerDaniel Bermond2023-04-02 12:36:11 -0300
commit9878083aac2fec5e72cd3f3b760751589bae672a (patch)
tree25767d2d9c9b64b1773136d93d8d281d1ba54b5b /PKGBUILD
parent324ca4fca6f0744e75a41a791eb5f2d7d45d5c6c (diff)
downloadaur-9878083aac2fec5e72cd3f3b760751589bae672a.tar.gz
Update to version 4.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cfa1cd8815b9..6e32329c41df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=4.3.1
+pkgver=4.4.0
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
@@ -10,39 +10,38 @@ license=('Apache')
depends=('gcc-libs')
makedepends=('git' 'cmake' 'python')
source=("git+https://github.com/ARM-software/astc-encoder.git#tag=${pkgver}"
- 'git+https://github.com/google/googletest.git'
- '010-astc-encoder-use-shared-library.patch')
+ 'git+https://github.com/google/googletest.git')
sha256sums=('SKIP'
- 'SKIP'
- 'b17d8f02273a0e58c9055dc5696965b62fbf833923b513d3685eda1af2cf13f4')
+ 'SKIP')
prepare() {
git -C astc-encoder submodule init
git -C astc-encoder config --local submodule.Source/GoogleTest.url "${srcdir}/googletest"
git -C astc-encoder -c protocol.file.allow='always' submodule update
- patch -d astc-encoder -Np1 -i "${srcdir}/010-astc-encoder-use-shared-library.patch"
}
build() {
cmake -B build -S astc-encoder \
+ -G 'Unix Makefiles' \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DSHAREDLIB:BOOL='ON' \
-DISA_AVX2:BOOL='ON' \
-DISA_SSE41:BOOL='ON' \
-DISA_SSE2:BOOL='ON' \
-DUNITTEST:BOOL='ON' \
-Wno-dev
- make -C build
+ cmake --build build
}
check() {
- make -C build test
+ ctest --test-dir build --output-on-failure
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
install -D -m644 astc-encoder/Source/astcenc.h -t "${pkgdir}/usr/include"
ln -s astcenc-sse2 "${pkgdir}/usr/bin/astcenc"
- ln -s libastcenc-sse2.so "${pkgdir}/usr/lib/libastcenc.so"
+ ln -s libastcenc-sse2-shared.so "${pkgdir}/usr/lib/libastcenc.so"
rm "${pkgdir}/usr/bin"/test-unit*
}