summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2021-07-23 17:07:51 +0000
committerDaniel Bermond2021-07-23 17:07:51 +0000
commitb35e0e2af087b72dddabc88b7269bd03e175f5fd (patch)
tree2ab47cf486f0deb15c03e912f820fef143bdad4b /PKGBUILD
parentf81c0ae3958a4cdf5822fcfde34701089441feac (diff)
downloadaur-b35e0e2af087b72dddabc88b7269bd03e175f5fd.tar.gz
Update to version 3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17dfb0becf37..ab3735f58498 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=3.0
+pkgver=3.1
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
@@ -11,16 +11,19 @@ depends=('gcc-libs')
makedepends=('git' 'cmake' 'python')
source=("git+https://github.com/ARM-software/astc-encoder.git#tag=${pkgver}"
'git+https://github.com/google/googletest.git'
- '010-astc-encoder-fix-install.patch')
+ '010-astc-encoder-fix-install.patch'
+ '020-astc-encoder-use-shared-library.patch')
sha256sums=('SKIP'
'SKIP'
- '32cb972d67318166273e6ca508270630bf329f5e1855502f6a493cd803ab2447')
+ '9c29ba69d8e9e10683ba965d2e13cdd939e477dcbef6e8d7700dc13d50cc9974'
+ 'df157a7b4041da008ca6ebeb7fbe7263ada7298e4e2190ba7f42b7871f881581')
prepare() {
git -C astc-encoder submodule init
git -C astc-encoder config --local submodule.Source/GoogleTest.url "${srcdir}/googletest"
git -C astc-encoder submodule update
patch -d astc-encoder -Np1 -i "${srcdir}/010-astc-encoder-fix-install.patch"
+ patch -d astc-encoder -Np1 -i "${srcdir}/020-astc-encoder-use-shared-library.patch"
}
build() {
@@ -41,5 +44,7 @@ check() {
package() {
make -C build DESTDIR="$pkgdir" install
+ install -D -m644 astc-encoder/Source/astcenc.h -t "${pkgdir}/usr/include"
ln -s astcenc-sse2 "${pkgdir}/usr/bin/astcenc"
+ ln -s libastcenc-sse2.so "${pkgdir}/usr/lib/libastcenc.so"
}