summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGaute Hope2018-08-30 11:01:52 +0200
committerGaute Hope2018-08-30 11:01:52 +0200
commitb9ff7b55e3cc44be0115cf20accf5690c2f06a5c (patch)
tree799b1978403f9e6a6723d395430a18bc98dd665f /PKGBUILD
parent3a110b38a299d631448f00dbf9baeb3b0fc968b4 (diff)
downloadaur-b9ff7b55e3cc44be0115cf20accf5690c2f06a5c.tar.gz
ship manpage
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 52927cc72742..7e4e442886e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gaute Hope <eg@gaute.vetsj.com>
_pkgname=astroid
pkgname=$_pkgname-git
-pkgver=v0.13.r21.g00a1fbb
+pkgver=v0.13.r24.g20b9171
pkgrel=1
epoch=
pkgdesc="a graphical threads-with-tags style, lightweight and fast, email client for notmuch, inspired by sup and others"
@@ -10,11 +10,12 @@ url="https://github.com/astroidmail/astroid"
license=('GPL')
groups=()
depends=('notmuch' 'boost' 'boost-libs' 'gmime' 'gtkmm3' 'webkit2gtk' 'libsass' 'libpeas' 'gobject-introspection' 'protobuf')
-makedepends=('cmake' 'ninja' 'git' 'pkg-config' 'python-gobject' 'cmark' 'ruby-ronn')
+makedepends=('cmake' 'ninja' 'git' 'pkg-config' 'python-gobject' 'cmark')
checkdepends=('notmuch-runtime')
optdepends=('gvim: default editor'
'emacs: can be used as editor'
- 'vte3: for drop-down terminal')
+ 'vte3: for drop-down terminal'
+ 'cmark: for markdown to html composition')
provides=('astroid')
conflicts=()
replaces=()
@@ -22,15 +23,20 @@ backup=()
options=()
install=$_pkgname.install
changelog=
-source=(astroid::git+https://github.com/astroidmail/astroid.git)
+source=(astroid::git+https://github.com/astroidmail/astroid.git astroid.1.gz)
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP'
+ '52c14022e2bf7e4806719e8ab4fb7909')
build() {
cd "$srcdir/astroid"
mkdir -p build
cd build
- cmake .. -GNinja -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+
+ # We ship the manpage to avoid an AUR dependency
+
+ cmake .. -GNinja -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DDISABLE_DOCS=ON
+
ninja
}
@@ -44,10 +50,13 @@ package() {
cd "$srcdir/astroid"
cd build
DESTDIR="$pkgdir" ninja install
+
+ # install manpage
+ mkdir -p "$pkgdir/usr/share/man/man1"
+ cp "$srcdir/astroid.1.gz" "$pkgdir/usr/share/man/man1/"
}
pkgver() {
cd "astroid"
git describe --long --tags --always | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
-