summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYigit Dallilar2019-03-01 11:50:44 -0500
committerYigit Dallilar2019-03-01 11:50:44 -0500
commitc4e7fa578c8832b3ee897a1f29f2afd7c005a2f8 (patch)
tree00464e01a57a99de401b274147a3e4958ef0323d /PKGBUILD
parent0720b8ca441745996726e428738ae78b3c81471d (diff)
downloadaur-c4e7fa578c8832b3ee897a1f29f2afd7c005a2f8.tar.gz
compile with openblas-lapack
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 2 insertions, 42 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 882e7be9d868..a8986a52f2ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=astromatic-scamp
_pkgname=scamp
pkgver=2.6.7
-pkgrel=2
+pkgrel=3
pkgdesc="computes astrometric and photometric solutions for any arbitrary sequence of FITS images in a completely automatic way."
url="http://www.astromatic.net/software/scamp"
arch=('x86_64')
@@ -16,49 +16,9 @@ backup=()
source=(https://github.com/astromatic/scamp/archive/v${pkgver}.tar.gz)
sha1sums=('e52abdf41c617f94dfc93a43d020b8e044f291ec')
-_use_mkl=0 # If you want to compile against intel mkl, make the value other than 0.
-
-# decide which library to compile against
-configure_options() {
-
- # First try intel-mkl if _use_mkl switch is on.
- if [ "$_use_mkl" != 0 ]; then
- _MKL=`pacman -Qq intel-mkl 2>/dev/null` || true
- if [ "$_MKL" != "" ]; then
- _COPTS="--enable-mkl"
- else
- echo "_use_mkl=1 but can not locate mkl libraries"
- exit 1
- fi
- echo "Compiling against intel-mkl"
- return
- fi
-
- # Try atlas-lapack first
- _ATLAS=`pacman -Qq atlas-lapack 2>/dev/null` || true
- if [ "$_ATLAS" != "" ]; then
- _COPTS=""
- echo "Compiling against atlas-lapack"
- return
- fi
-
- # If atlas-lapack not installed, fall back to openblas-lapack
- _OBLAS=`pacman -Qq openblas-lapack 2>/dev/null` || true
- if [ "$_OBLAS" != "" ]; then
- _COPTS="--enable-openblas --with-openblas-incdir=/usr/include"
- echo "Compiling against openblas-lapack"
- return
- fi
-
- # If all fails exit and throw error.
- echo "Failed to locate appropriate library: atlas-lapack, openblas-lapack, intel-mkl"
- exit 1
-}
-
-
build() {
- configure_options
+ _COPTS="--enable-openblas --with-openblas-incdir=/usr/include"
cd $srcdir/${_pkgname}-${pkgver}
sh autogen.sh