summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F Rødseth2017-11-24 17:57:02 +0100
committerAlexander F Rødseth2017-11-24 17:57:02 +0100
commit9fd328b62bd9ae7c8d5a13062ad440d9b925ddfc (patch)
tree134ccdd75fa7f42d6e613166eb2262380b9cf133 /PKGBUILD
downloadaur-9fd328b62bd9ae7c8d5a13062ad440d9b925ddfc.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52ba54a8ea1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+pkgname=asublim
+pkgver=0.1
+pkgrel=1
+pkgdesc='Clone of the xsublim screensaver'
+arch=('x86_64')
+depends=('xorg-rgb' 'xorg-xlsfonts' 'xosd' 'zsh')
+makedepends=('git')
+source=("git+https://github.com/enkiv2/asublim#commit=b642015ac9ecc874b0f89f6c2c4b3a3fc5562781")
+md5sums=('SKIP')
+
+prepare() {
+ sed -i "s,/usr,$pkgdir/usr,g" "$pkgname/Makefile"
+ sed -i 's,/etc/X11,/usr/share/X11,g' "$pkgname/sublimWrap"
+}
+
+build() {
+ make -C "$pkgname"
+}
+
+package() {
+ install -Dm755 "$pkgname/sublim" "$pkgdir/usr/bin/asublim"
+ install -Dm755 "$pkgname/sublimWrap" "$pkgdir/usr/bin/sublimWrap"
+}
+
+# vim: ts=2 sw=2 et: